Daisy Museum Homepage
Forum Home Forum Home > Daisy Airguns > Questions
  New Posts New Posts RSS Feed - Help Fixing Daisy 1894 Rifle
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Help Fixing Daisy 1894 Rifle

 Post Reply Post Reply
Author
Message
shagfullmetal View Drop Down
Newbie
Newbie
Avatar

Joined: June-13-2020
Location: California
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote shagfullmetal Quote  Post ReplyReply Direct Link To This Post Topic: Help Fixing Daisy 1894 Rifle
    Posted: June-13-2020 at 1:02am
Hi everyone im new to the forum, but not new to daisy air rifles. I have a model 1894 NRA Centennial 1971 bb rifle, its in near perfect condition, the seals were old and dried up after 50 years, my question? I just replaced the seals on this rifle i had to sand them down to fit in the compression chamber, and the bbs definitely fly a bit further vs just rolling out of the barrel, the rifle just lacks power, idk if this is how these rifles were straight out of the factory, but it doesn't even have enough power to go through an empty soda can, i have to shoot the same spot twice for it to go through a soda can at point blank range. Is this common with these rifles, or may there be another issue?
Thanks for any reply :)
Back to Top
Bavaria55n View Drop Down
Red Ryder Member
Red Ryder Member


Joined: October-12-2015
Location: CentralIllinois
Points: 636
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bavaria55n Quote  Post ReplyReply Direct Link To This Post Posted: June-13-2020 at 9:31am
Some that are more knowledgeable will chime in.
The 1894 has a taper in it. Poor design that deforms the seal if the gun is not kept cocked.
Perhaps you sanded off too much?
Gary
Back to Top
shagfullmetal View Drop Down
Newbie
Newbie
Avatar

Joined: June-13-2020
Location: California
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote shagfullmetal Quote  Post ReplyReply Direct Link To This Post Posted: June-13-2020 at 2:49pm
Howdy Gary, thanks for the reply :), i dont believe i sanded off too much, i sanded a little bit at a time and kept testing it, the results were at first, it was having a lot of drag, not enough travel speed to add any power. Kept sanding little by little and testing, i feel as if I'm at a point where if i sand any more it would have no compression, its shooting at its strongest point, but its still really weak haha. Wondering if it would help if i made a video showcasing the issues??
Back to Top
twocompassheads View Drop Down
Red Ryder Member
Red Ryder Member
Avatar

Joined: March-21-2017
Location: Kingman, AZ
Points: 138
Post Options Post Options   Thanks (0) Thanks(0)   Quote twocompassheads Quote  Post ReplyReply Direct Link To This Post Posted: June-15-2020 at 8:06pm
I tried the last three 1894's that I rebuilt and the normal velosity is around 270fps and it could vary from 250 up to 300.  There are a few things that can cause your lack of power.  I shot this 7up can from 20  feet away and did not even see the BB go through.  At 20+ yards I can see the BB because it's slowing down.  the 1894 is probably one of the weakest shooting guns from Daisy, but is pretty accurate.  some of the things that could be causing this I will try and cover.  The gun is 50 years old and not seeing it and looking it over there could be some issues.  Possibly your seal might be too small now and did you replace the abutement seal?  The shot tube is rolled and could have a slight opening in the seam, causing lose of power.  The air tube could be a little dirty or partially plugged if it wasn't cleaned out with a wire or proper size drill.  The airchamber can have a crack in the weld or the staking is too deep causing air to bypass the abutment seal.  The picture I posted will show a barrel that has been staked by someone over the years after the factory did it causing it too be too deep and the seal to not seat on the air chamber and bypass when fired.  I always super glue my abutment seal to the feed bushing when installing new.  The spring could be collapsed and is weak.  There could be other reasons but hard to tell not seeing the gun.
Ride and Have Fun
Back to Top
BB1Shooter View Drop Down
Red Ryder Member
Red Ryder Member


Joined: April-23-2019
Points: 227
Post Options Post Options   Thanks (0) Thanks(0)   Quote BB1Shooter Quote  Post ReplyReply Direct Link To This Post Posted: June-16-2020 at 4:59pm
Great advice TwoCompassheads.
I also find that most of my Daisy/Sears/Winchester 1894 BB guns are shooting in the 250-290 range. I suspect that is the normal for them. Esp. given most are 40+ years old.
 
 
Back to Top
cobalt327 View Drop Down
Red Ryder Member
Red Ryder Member
Avatar

Joined: November-15-2013
Points: 1951
Post Options Post Options   Thanks (0) Thanks(0)   Quote cobalt327 Quote  Post ReplyReply Direct Link To This Post Posted: June-16-2020 at 11:06pm
Good info as always, TCH!

I'm guessing the part inside the yellow box acts as a pilot to keep things in alignment?



Back to Top
twocompassheads View Drop Down
Red Ryder Member
Red Ryder Member
Avatar

Joined: March-21-2017
Location: Kingman, AZ
Points: 138
Post Options Post Options   Thanks (0) Thanks(0)   Quote twocompassheads Quote  Post ReplyReply Direct Link To This Post Posted: June-18-2020 at 10:52pm
Cobalt327  Yes, it is inside the deep socket and aligns the seal perfectly.  It's an old one that broke the tab off the top of the hole, I slide it back and forth a few times to make sure it will move if any glue got on it. I always stay away from the hole by about an 1/8 inch just in case.  I use the gel type glue and use a tooth pick and just put a film on it.   
Ride and Have Fun
Back to Top
cobalt327 View Drop Down
Red Ryder Member
Red Ryder Member
Avatar

Joined: November-15-2013
Points: 1951
Post Options Post Options   Thanks (0) Thanks(0)   Quote cobalt327 Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2020 at 8:34pm
That's good thinking!
Back to Top
shagfullmetal View Drop Down
Newbie
Newbie
Avatar

Joined: June-13-2020
Location: California
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote shagfullmetal Quote  Post ReplyReply Direct Link To This Post Posted: June-24-2020 at 5:44am
That's fantastic information thank you! I believe my rifle shoots slower than 250-300 fps more likely 120 to 150 max but i dont have a chronograph to test it, it still won't puncture from point blank range. And i just installed a newer seal, not the one i shaved, i want to put in the abutment washer that came with it but i have no clue on how to remove the one i installed from the other seal kit?. Do you have an email address? Or any way i can send pictures/ videos? I can fully disassemble the rifle and show you everything! I have a new abutment washer in the rifle, but i have no idea how to remove it, now it's permanently in there. I would love any help and advice you can provide.
Back to Top
twocompassheads View Drop Down
Red Ryder Member
Red Ryder Member
Avatar

Joined: March-21-2017
Location: Kingman, AZ
Points: 138
Post Options Post Options   Thanks (0) Thanks(0)   Quote twocompassheads Quote  Post ReplyReply Direct Link To This Post Posted: June-26-2020 at 7:14pm
Shagfullmetal,  I would like to see any pictures you have of your gun and the washer your talking about.  I can help you try and locate your problem and tell you what to do or any issue that you may have.  Send me and email at    den4570@yahoo.com     and we can talk about this.    Dennis

P.S.  The newer 1894's, lets say in the late 70's or so didn't have abutment washers, it all depends on the location of the barrel bushing( this is the bushing that is spot welded in place by the factory, most have 6 spot welds and later on in production they only had 4 spot welds), if the barrel bushing is right at the edge of the opening it won't use a washer, if the bushing is located forward of the opening about the thickness of a washer then it should have one.  I think I have a picture of this, if I do then I will post it.
Ride and Have Fun
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.03
Copyright ©2001-2015 Web Wiz Ltd.